[CentOS] FTP timout

Wed Aug 24 13:04:06 UTC 2005
Abd El-Hameed Ayad <hamid at use-trade.com>

One of the servers is vsftpd & the other is pure-ftpd
if i logged to server running vsftpd and tried to download any file, i can 
do that without problems regardless the size of the file.
But if i logged to the server running pure-ftpd & tried to upload the same 
file, i get the time out message "Note here: The timeout always happens 
after the file completely uploaded, the ftp client hangs then gives the 
timeout message "

Also, If i logged to the server running pure-ftpd, i can use ftp command to 
download any file from vsftpd server but i can't upload the same file back 
to the server if this file size is big

Do you think that i should edit the configuration file for pure-ftd or 
vsftpd? If yes, Which parameter i should change

Thank you for your concern.

----- Original Message ----- 
From: William A. Mahaffey III
To: CentOS mailing list
Sent: Wednesday, August 24, 2005 3:32 PM
Subject: Re: [CentOS] FTP timout

Abd El-Hameed Ayad wrote:
Hi all,
    I have 2 CentOS 3.5 boxes & i do backups on the LAN
Recently, I always get FTP timout error with large files "700 MB and more" .

i tried to log and do manual backup with FTP command and i also got the same 
result "FTP timeout"

i tried to google and i did
# modprobe ip_conntrack_ftp
but still get the same timeout message

Any one can help???


'man ftpd' at a shell prompt should point you to the ftpd configuration file 
where that timeout can be reset. Might be 'wsftpd' or some other name, try 
'apropos ftp' at a shell prompt to get a list of available man entries on 
ftp/ftpd/etc. YMMV, HTH, & all that :-).

 William A. Mahaffey III
 Remember, ignorance is bliss, but
 willful ignorance is LIBERALISM !!!!

CentOS mailing list
CentOS at centos.org