[CentOS] Can't mount FAT32 partition

Tue Aug 30 02:34:21 UTC 2005
Craig White <craigwhite at azapple.com>

On Tue, 2005-08-30 at 11:08 +0900, Dave Gutteridge wrote:
> Okay, the current /etc/fstab file has this entry in it:
> /dev/hda1               /mnt/windows            vfat    
> rw,noauto,user,uid=512,gid=1002 0 0
> When I run "mount -a", I get no errors.
> But when go to the /mnt/windows directory at the command line, it's empty.
> In Nautilus, I get an icon for the new drive, but if I click on it, I 
> get that same error as before:
> wrong fs type, bad option, bad superblock on /dev/hda, or too many 
> mounted file systems
> I had no trouble before with CentOS detecting and using a Fat32 external 
> hard drive, connected by firewire. Why is this drive behaving differently?

- mount is not made by same user doing cd /mnt/windows
- mount is not made by same user running gnome/nautilus
- mount references /dev/hda1 but hard drive has different device

dmesg| less #check to see if the drive is assigned a different letter
df -h shows mounted filesystems and usage
are you user 512?
are you running mount as yourself and not root?
has the drive been fixed with scandisk/checkdisk since the assault by
linux fsck?

short answer, it shouldn't make a difference being connected via
internal IDE or external firewire except as external firewire, it would
be assigned something more like /dev/sda instead of /dev/hda