[Centos] an RPM conundrum

Tue Jan 11 00:56:57 UTC 2005
Barry L. Kline <blkline at attglobal.net>

I have an interesting chicken-and-egg problem that I hope someone can help me 
out of.

I have a machine on which I originally loaded White Box.  I subsequenty 
converted to CentOS using the instructions found numerous times in the group 
-- e.g. get the redhat-package RPM  (thus changing /etc/redhat-release), then 
configuring yum and then yum -y upgrade.

Everything has been going fine... that is until I tried installing the 
rpm-build package.  Now I'm getting the message:

[root at intranet root]# yum install rpm-build
Gathering header information file(s) from server(s)
Server: CentOS-3.3 - Addons
Server: CentOS-3.3 - Base
Server: CentOS-3.3 - Extras
Server: CentOS-3.3 - Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package rpm-build needs rpm = 4.2.3-10, this is not available.

Which I assume is caused by my version of rpm:  rpm-4.2.3-10.WB1

I can't seem to figure out how to convert RPM packages and, of course, I can't 
simly rpm -e rpm and then use the erased package to install itself.   I've 
tried a simple yum --download-only ...  but the dependency check still 

Any thoughts on what to try next?