[CentOS] Hosed by 4.2 [solved]

Paul Heinlein heinlein at madboa.com
Tue Nov 1 14:11:14 UTC 2005

On Tue, 1 Nov 2005, Johnny Hughes wrote:

> On Mon, 2005-10-31 at 10:35 -0800, Paul Heinlein wrote:
>> On Mon, 31 Oct 2005, Syv Ritch wrote:
>>> I have finally solved the problem.
>>> The problem IS [present tense] X. X dies with the ATI card. I have
>>> tried changing the driver to ATI's, and still no dice. I ended
>>> cannibalizing an older PC and changing the video card to an nVidia
>>> GeForce2. Everything works well.
>>> Something's wrong on how X talks or does not talk to the ATI9200.
>>> It's not the driver because it happens with both dri and fglrx, so
>>> ...
>> Same thing with the Radeon 7000 series...
> Guys,
> This is a known issue with a patch on the 6.8.2 version of xorg-x11.  It
> is an upstream issue.
> Pasi Pirhonen (one of our CentOS developers) found and reported the
> issue upstream.
> In the meantime, I believe if you disable dri in your /etc/X11/xorg.conf
> file everything will work (except 3D).

Sadly, disabling dri didn't work for me. Taking a look at ticket 
#170008 at bugzilla.redhat.com suggests that others are experiencing 
the same trouble.

Just as sadly, I haven't yet taken the time to poke around the xorg 
sources to see if any patches have been commited that claim to fix the 

-- Paul Heinlein <heinlein at madboa.com>

More information about the CentOS mailing list