[CentOS] CUPS and Okidata ML 395

Kanwar Ranbir Sandhu m3freak at rogers.com
Fri Nov 11 05:02:30 UTC 2005

Hi All,

Has anyone currently, or in the past, setup an Okidata ML 395 (or any of
Okidata's impact printers, for that matter) on a CentOS box?  I'm having
a miserable time with the ML 395: I'm looking for some tips.

I have an AMD Opteron server running CentOS 4 (x86_64).  CUPS is running
happily for two Canon imageRunner's (via BrightQ Pro from Codehost).
The Okidata ML 395 is attached to the server with a parallel cable.
When I configure the Okidata printer with system-config-printer, I
choose the ML 395B driver, and leave all other driver settings at
defaults.  Things look good at this point.  However, when a print job is
submitted, all I get is a few letters on separate lines.

I've tried other drivers:

- Epson 24 pin series
- Epson LQ 870
- Okidata 24 pin series

None have worked.  There is either no output at all, or it's messed up.

As a temporary fix, I finally resorted to connecting the printer to a
Windows box, sharing it, and printing to it from the CentOS server via
the Samba backend in CUPS.  This isn't ideal because I want everything
on the CentOS server.

I've tried everything I can think of, and I believe I've exhausted the
little info available on the web.  I've also asked Okidata for support,
but I haven't received any replies to my support requests.

If anyone could help to shed some light on this, I would be grateful.  

Thanks in 
Kanwar Ranbir Sandhu
Systems Aligned Inc.

More information about the CentOS mailing list