[CentOS] CUPS problem with network printing - SOLVED!!! :)))

Olaf Greve o.greve at axis.nl
Fri Nov 11 12:47:05 UTC 2005

Hi all,

Yesterday I reported rather vaguely about the printing issues I was 
experiencing on our local network after the latest kernel update.

Today, I solved it, and I'm relaying this information such that others 
can potentially benefit from it if they run into a similar problem. :)

Firstly, I contacted Xante support and they told me I was the first to 
ask Linux questions; they didn't know what to do... So much for their 
tech support, so I then took the bull by the horns myself, and went 
through a debug process.

The printer I need to print to has now been shared through a Mac OS X 
machine, which has printers shared and these printers (two in total) 
appear properly in the "browsed queues" in Gnome's printer set-up utility.

However, printing a test page (either as ASCII, CUPS, or Postscript) 
still didn't work.

I raised the debug level to the max (i.e. "debug2") in 
/etc/cups/cupsd.conf and restarted cupsd. Checking the 
/var/log/cups/error_log shows the following relevant debug trace of a 
failed "print ASCII test page" command from the printer utility:

I [11/Nov/2005:12:58:36 +0100] [Job 5] Connecting to 
dymo-labelwriter.local on port 631...
I [11/Nov/2005:12:58:36 +0100] [Job 5] Unable to connect to 
dymo-labelwriter.local, queuing on next printer in class...
d [11/Nov/2005:12:58:37 +0100] select_timeout: 86400 seconds to browse 
timeout a printer

Soooo, the issue obviously resided in CUPS not being able to connect to 
port 631 on the MacOSX machine. This is where it got interesting, as I 
checked the MacOSX machine and that port was open (listing "IPP" as 
port-listener). Doing a remote port scan by the MacOSX's IP address 
showed a proper list of open ports, and doing so by the alias 
dymo-labelwriter.local only resulted in a 'host unknown' error.

OMG; how blatantly obvious yet easy to overlook this issue now all of a 
sudden became! :P
Indeed... Adding the dymo-labelwriter.local alias with it's 
corresponging IP address to the /etc/hosts file did the trick. Now it 
works fine again!

Live and learn....;)

'Ave a good weekend!

More information about the CentOS mailing list