[CentOS] Recommendation(s)

Sam Drinkard sam at wa4phy.net
Sat Oct 1 18:28:07 UTC 2005

As far as I know Les, the 2.3.3 does exist, but not under RH, Centos or 
the "big 3" for that matter.  I recall seeing a few rpm pkgs for some 
distros I've never heard of.  As for it being exactly what is needed, I 
can't say anything for sure, other than what the runtime error prints 
out.  I've looked in the librt.so.1, and it does in fact have an 
external call to 2.3.3, but beyond that, I dunno.  It could well be a 
compiler error too.  Many of the folks who have had success building and 
running WRF are doing so under an earlier version of the PG compiler, I 
think pre-6.0.  Since I don't own the portland group compiler, just 
using the trial version, I'm not entitled to any support from them, and 
as I stated earlier, there has been little to no discussion about late 
date versions of Linux.  The other thing that is secondary to the WRF 
build is some fortran utilities and one shared object file that will not 
build under the x86-64 due to some relocation issues.  I think all the 
code that I'm attempting to build/run was pretty well tested out on the 
i386 versions of several OS', but primarily RH3.

On another note, I do have folks that have sent me some configuration 
files for the MM5 model running under the x86-64 RH distro, and they all 
say it really kicks ass compared to the 32-bit builds, but that is 
again, using an earlier version of the Intel compiler and earlier code 
to boot.  I'm not one to stay on the bleeding edge of things, but I 
figured there would not be too much change from 3 to 4, but I'm finding 
out different.  As for the actual 2.3.3 library, I don't know if it will 
be in the 3.5 distro of Centos or not, but its worth a try.

Les Mikesell wrote:

>There is an x86_64 version of Centos3.5.  But, I think both
>will have gcc-3.2.3 which should be the libraries that match
>compat-glibc on 4.x.  Are you sure you need exactly 2.3.3?


More information about the CentOS mailing list