[CentOS] Cron script crashing server...

Abd El-Hameed Ayad hamid at use-trade.com
Mon Oct 3 10:49:48 UTC 2005

    Try to monitor your server performance via top while cron is running with run_stats.sh script.
It will give you an idea about what is being done? Does this process takes a lot of CPU or spawns other processes that consumes a lot of CPU of memory

I got such behavior with Apache+PHP (running as CGI)+MySQL on CentOS 3.5 and i found that MySQL was taking about 90% CPU before the server dies with nothing could be done except cold booting.

If you have a similar problem, Let us determine which process exactly is doing this biss-behaviour and try to find alternatives.

  ----- Original Message ----- 
  From: Ian mu 
  To: centos at centos.org 
  Sent: Monday, October 03, 2005 11:30 AM
  Subject: [CentOS] Cron script crashing server...

  Hiya, have a bit of an odd problem so looking for thoughts before proceeding any more.

  Problem is on centos3 (also runs fine on another but fails on another, so not sure this is an issue or not), dual xeon setup.

  Basically I have a perl script that runs once, first thing every morning, gathering some stats (currently turned off due to problem). Crontab -l shows the following...

  00 6  * * * nice /home/statsman/stats/run_stats.sh  >/dev/null 2>&1 (.sh file basically sources with full path a config with some vars, then runs the perl script).

  There are a couple of other scripts in the crontab which run absolutely fine, so cron itself seems to be working, its just the combination.

  If I run this (at that time or anytime) via cron, the whole server totally dies no warning, nothing in logs instantly. If I watch in top waiting for the cron you don't even see it appear, machine just totally hangs, can't ping or anything, needs a cold boot. Nothing in logs or anything apart from bootup info after. 

  If I run the perl script outside of cron from any folder at all, it works fine, never crashes which is where I'm confused, its only as soon as its run from cron. To test I've put it on a test machine, and to confuse it further runs absolutely fine under cron (old redhat install though) no matter what I do, it also seems to run fine on other machines (except one with identical problem) and runs fine from cron on other linux dists/machines, but can't do as much testing on them. 

  I'm really not sure where the problem lies, so may be offtopic, I'm just confused why it runs on some and not others (although maybe running the same version, its possible they were configured slightly different on install), and pretty much clutching at straws. Worse thing is machines a production one, and want to keep downtime to a minimum, so trying to get some angle on what may be wrong before testing more. 

  Any thoughts much appreciated.



  CentOS mailing list
  CentOS at centos.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20051003/cafe64d2/attachment.html>

More information about the CentOS mailing list