[CentOS] segmentation fault

Cameron Showalter cameron at gwschool.com
Thu Oct 6 00:07:28 UTC 2005

running Centos 4.1 i386 on a poweredge 1800, will be trying x86_64 
tomorrow since apparently the processors are EM64.   anyhow, I'm having 
issues with this unit producing segmentation faults on practically 
everything.   this is not an issue just with Centos 4.x, but also RHEL 
3.  so I resorted to RH9, but had other issues with hardware drivers. 

Today, I installed OS and everything went smoothly, to a point.  this 
server will ultimately be used for a point of sale application called 

What I did was install the app (worked great), installed an sql 
interface to the db (worked great).  added some data to the db and 
posted sales.   This is where I have the continual problems with linux.  
as soon it starts the posting, in another windows I did a ps -ef and got 
Segmentation fault, dmesg produces the same error.   top still works, 
but thats about it.  now, from experience, I know that if I reboot the 
system - I'll get many errors and segmenation faults and then when the 
login comes back up where the name of the server is will be () login: 

I'm guessing there is going to be no way around reinstalling this box, 
but I trying to remain hopeful that there is a better solution.


More information about the CentOS mailing list