[CentOS] ant RPM for CentOS 4

Aleksandar Milivojevic alex at milivojevic.org
Thu Oct 6 18:38:00 UTC 2005

Quoting Ignacio Vazquez-Abrams <ivazquez at ivazquez.net>:

> On Thu, 2005-10-06 at 12:05 -0500, Aleksandar Milivojevic wrote:
>> Attempting to build OpenOffice 2 on CentOS 4 from rawhide (future FC5) SRPM.
>> The spec file has EL4 target (which is nice), and I got almost all 
>> dependencies
>> in place (mostly from 4.2beta and some from rawhide).  However, I'm 
>> missing the
>> ant package.  Ant from rawhide doesn't compile since it is already 
>> gcc 4 based
>> (fails on dependencies, getting it to use gcc4 instead of gcc seems 
>> like nice
>> piece of work, but I might be wrong, I might need to do it after 
>> all).  Similar
>> story with FC4 ant SRPM.  CentOS doesn't have ant RPM at all.  FC3 
>> (which is the
>> closest match to EL4/CentOS4) doesn't have it either.
>> Has anybody managed to rebuild ant SRPM on CentOS 4.x?
> Did you try JPackage?

Not yet, but I'll give it a try.  There's no el4 specific RPM, so I'll 
try with
generic one.  The only thing I'm affraid is that it will use java from gcc
package (gcc v3), while openoffice itself depends on java from gcc4 
package. Anyhow, I'll try and see how it works out.

This message was sent using IMP, the Internet Messaging Program.

More information about the CentOS mailing list