[CentOS] CentOS-4/beta/preview version immediate availability

Aleksandar Milivojevic alex at milivojevic.org
Tue Oct 18 19:51:01 UTC 2005

Quoting Pasi Pirhonen <upi at papat.org>:

> I've tested the installation to
> - U10
> - U30
> - Netra T1405 (quad)
> - Netra/X1

I just did an install on SunFire v100 (similar machine to Netra X1).  Works
nicely.  Created /boot as normal partition, and than created software RAID-1
and used it as physical volume and put the rest of the system under 
LVM.  Since
it was text install, I had to do LVM stuff manually from command line before
using "disk druid" (LVM dosn't have GUI in text installs, and I didn't want to
use autopartitioning).  The "workstation" install took about an hour to
complete from the CDs.

First experiences and couple of things to notice for folks trying to 
install on
Sparc hardware.

The kernel is "kernel-2.6.9-22.EC"?  Shouldn't it be 
"kernel-2.6.9-22.EL"? Typo?  On purpuse?

If Solaris kernel was up and running before booting CentOS install CD, the
machine might need to be powered off first.  This is something specific to 2.6
kernel (2.4 kernels do not have that problem).  I'm not sure if this is needed
when booting 2.6 kernel for the very first time, or every time after Solaris
kernel was loaded.  At least this is true on Sun Enterprise 150 and SunFire

When creating partitions, leave third partition to be "entire disk".  This is
not really needed under Linux, but it is customary on Sun boxes (and if you
dual-boot, you probably want to have it that way to keep Solaris happy).

Supposedly /boot can't be on software RAID-1.  I remember this back 
from Aurora
days.  Don't remember if it was SILO limitation or something else.  Haven't
attempted to put /boot on software RAID-1 on CentOS, so who knows, maybe it
works now after all...

There are no virtual consoles on headless systems (aka console over serial
port).  At least not as far as I know.  However, you can get command line by
pressing ctrl-z on any Anaconda screen.  Type "exit" to get back to Anaconda.

On SunFire v100 network interfaces are detected in reverse order.  What 
sees as dmfe0 is eth1 under Linux, and what Solaris sees as dmfe1 is 
eth0 under
Linux.  Needless to say, labels on the back of the box correspond to 
how Solaris
sees them.  Also, the LED for first ethernet port (dmfe0 under Solaris, eth1
under Linux) flashes like crazy, although there's no cable connected to it and
the interface is not configured.

The text version of firstboot is ugly, at least in minicom.  You'll 
have trouble
navigating it.  But be brave, I've seen worse ;-)

I've attempted connecting USB DVD-burner.  No luck.  Bunch of error messages
logged by the kernel, and udev creates /dev/uba (!?) device for it.  USB stick
worked and I got /dev/uba* devices created for all partitions found on USB
stick.  However, /etc/fstab and /media directory were not updated (as 
on i386).
While I'm at it, there's also no entries for IDE CD-ROM in /etc/fstab file and
/media directory.

This message was sent using IMP, the Internet Messaging Program.

More information about the CentOS mailing list