[CentOS] CentOS-4/beta/preview version immediate availability

Pasi Pirhonen upi at iki.fi
Tue Oct 18 20:57:53 UTC 2005


On Tue, Oct 18, 2005 at 02:51:01PM -0500, Aleksandar Milivojevic wrote:
> I just did an install on SunFire v100 (similar machine to Netra X1).  Works
> nicely.  Created /boot as normal partition, and than created software RAID-1
> and used it as physical volume and put the rest of the system under 
> LVM.  Since
> it was text install, I had to do LVM stuff manually from command line before
> using "disk druid" (LVM dosn't have GUI in text installs, and I didn't want 
> to
> use autopartitioning).  The "workstation" install took about an hour to
> complete from the CDs.

So now i know the software RAID1 works too. I don't use RAID on my
build machines. I do have all the important information on my
NFS-server, so i can just toss a machine, install it again, vonfig few
things and i am good to continue from where i left on updates build or

> The kernel is "kernel-2.6.9-22.EC"?  Shouldn't it be 
> "kernel-2.6.9-22.EL"? Typo?  On purpuse?

That is not a typo. It's intentional and the abrevation would be
'Enterprise Compatible'. I've used it long time for my 'heavily patched
versions of same codebase' just to make it clearly different from .EL.
line which are mostly unmodified.

> If Solaris kernel was up and running before booting CentOS install CD, the
> machine might need to be powered off first.  This is something specific to 
> 2.6
> kernel (2.4 kernels do not have that problem).  I'm not sure if this is 
> needed
> when booting 2.6 kernel for the very first time, or every time after Solaris
> kernel was loaded.  At least this is true on Sun Enterprise 150 and SunFire
> v100.

I have no info on this area. generally it's one machine - one OS for me
anyway. Someone might find this info interesting tho.

If you talk about Aurora 1.0 as 2.4-kernel -> it has different version
os SILO too. SILO is the loader which is booted from disk, so that
might be more like SILO related than kernel related.

> When creating partitions, leave third partition to be "entire disk".  This 
> is
> not really needed under Linux, but it is customary on Sun boxes (and if you
> dual-boot, you probably want to have it that way to keep Solaris happy).

I am aware of this. The util-linux (mount command) is patched spcially
for not complaining about duplicate LABELs found if for example partion
1 is /boot, so partition 3 would have /boot label too visible.

Anaconda still installs sun disk label IMO on disks, so the '3 - whole
disk' is there. And what i've tested (/boot, / and swap which make
three paritions) anaconda nicely skips the 3rd parition and leaves it
as 'whole disk'.

> Supposedly /boot can't be on software RAID-1.  I remember this back 
> from Aurora
> days.  Don't remember if it was SILO limitation or something else.  Haven't
> attempted to put /boot on software RAID-1 on CentOS, so who knows, maybe it
> works now after all...

It must be SILO. But i remember yaboot just recently getting the 'boot
from mirrored disk support', so sparc has not been alone on this. On
ia64 one can't mirror the /boot VFAT partition either, so it's no like
unique for sparc.

> There are no virtual consoles on headless systems (aka console over serial
> port).  At least not as far as I know.  However, you can get command line by
> pressing ctrl-z on any Anaconda screen.  Type "exit" to get back to 
> Anaconda.

That is general trick, but good to know. One could boot to rescue mode
too and use the shell there to make what even needed (ctrl-z would be
quiker tho).

> On SunFire v100 network interfaces are detected in reverse order.  What 
> Solaris
> sees as dmfe0 is eth1 under Linux, and what Solaris sees as dmfe1 is 
> eth0 under
> Linux.  Needless to say, labels on the back of the box correspond to 
> how Solaris
> sees them.  Also, the LED for first ethernet port (dmfe0 under Solaris, eth1
> under Linux) flashes like crazy, although there's no cable connected to it 
> and
> the interface is not configured.

same on Netra/X1. I don't know if tweaking the probe-order on PROM
would fix this for PROM. Tweaking Linux PCI-probes for something so
simple would be overkill IMO. 

> The text version of firstboot is ugly, at least in minicom.  You'll 
> have trouble
> navigating it.  But be brave, I've seen worse ;-)

Fortunately you can just leave it there and it'll timeout dooner or
later :)

> I've attempted connecting USB DVD-burner.  No luck.  Bunch of error messages
> logged by the kernel, and udev creates /dev/uba (!?) device for it.  USB 
> stick
> worked and I got /dev/uba* devices created for all partitions found on USB
> stick.  However, /etc/fstab and /media directory were not updated (as 
> on i386).
> While I'm at it, there's also no entries for IDE CD-ROM in /etc/fstab file 
> and
> /media directory.

USB might be something wort invertigating. That was quite out of scope
for making the damn thing installable for wider public. As i've been
saying, it's a start and i do hope getting feed back to make it release
as of time of CentOS-4.3 time. There is lot of fixing and so little
time :)

Primary goal is to get it installed. When it's OK, it's much easier to
provide just updates to installed system and get new working features

For above, it's nice to hear that even something IS working under USB

Pasi Pirhonen - upi at iki.fi - http://iki.fi/upi/

More information about the CentOS mailing list