[CentOS] corrupt rpm problem

Jim Perrin jperrin at gmail.com
Fri Oct 21 00:31:00 UTC 2005

On 10/20/05, Peter Farrow <peter at farrows.org> wrote:
>  Hi Jim,
>  yes I did add the line you suggested straight away and indeed shows the
> multi-arch packages as you describe...
>  however the yum snapshot was consitent with and without the macro
> definition for rpm, and still doesn't work.

Okay, so if it's listing both versions of the same package, then the
next step is to check yum to see what's available, WITH the script in
.rpmmacros. 'yum list packagename' should show you the packages
available. My suspicion is that there's an upgrade for one, but not
the other, which would lead to your conflict. If this is indeed the
case, please paste the versions and the yum output here (again, with
the script in .rpmmacros) so that we can see where the problem is. It
may be something on the repository end that was overlooked, or it
could be something as simple as removing one of the packages. To be
safe, I'd like to see what's there before I say to just go ahead and
uninstall one of them.

Jim Perrin
System Administrator - UIT
Ft Gordon & US Army Signal Center

More information about the CentOS mailing list