[CentOS] Yum update crashed, now I have lots of missing deps

Remco Barendse redhat at barendse.to
Fri Oct 21 10:00:40 UTC 2005

On Fri, 21 Oct 2005, Karanbir Singh wrote:

> Remco Barendse wrote:
>> Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package 
>> libmudflap-devel
>> Error: Missing Dependency: kdebase = 6:3.3.1-5.5 is needed by package 
> ( this issue along with the 'existance of more than 1 instance of the same 
> pkg name' has been discussed previously a few times, look through the recent 
> archieves for the relevant .rpmmacros etc )
> firstly, check what mirror you are using in /etc/yum.repos.d/CentOS-Base.repo 
> - make sure that is responsivle ( and  local to you - check 
> http://www.centos.org/mirrors for a list of mirrors )
> Then remove all files from the /var/lib/rpm/ directory except the Packages 
> file, and run
> rpm -v --rebuilddb
> yum clean all
> yum update yum
> yum update kernel* audit*
> reboot
> yum -y update
> Let us know how you get along.

It seems that the previous updates have made a complete mess of my system, 
about every package is there at least 3 times.

Will the above solve this problem too?

I'm hesitating a bit to complete the above steps in order not to increase 
the mess.

I tried it with samba packages (I had 5 packages of samba-common 
installed) removed the lot and reinstalled everything. Now samba seems to 
be clean but if I have to do this for tevery package (about 150!!) I'm 
better off re-installing the box....

Any advice greatly appreaciated


P.S. Sorry for top posting

More information about the CentOS mailing list