[CentOS] vsftpd failing since upgrade to 4.2

scott scott.list at mlec.net
Mon Oct 24 02:27:22 UTC 2005

My vsftpd was working.  I use it configured via xinetd and turn it off 
(disabled = yes)  when I'm not using it to keep the bad guys from hammering 
on it.

Recently I upgraded to 4.2 (via yum update).  That' the only change I know 
of on the system.  And I didn't have any problems with it.

Today when I try to ftp, i enabled it in xinetd.d (with disable = no and a 
"service xinetd restart")  But I can't connect.  Well, I connect, but then 
I'm dropped with the reply:

500 OOPS: cannot open config file:/etc/vsftpd/vsftpd.conf

The config file is there:
-rw-------   1 ftp  ftp  4271 Oct 23 21:03 vsftpd.conf

I haven't changed it's permissions.

the ftp account appears intact:
ftp:x:14:50:FTP User:/var/ftp:/sbin/nologin

There are no related entries on tehlog, only the connect in /var/log/secure:
Oct 23 21:11:58 tn1 xinetd[13086]: START: ftp pid=13113 from=xx.xx.xx.xx

I tried starting it manually via service vsftpd start.  That appeared to 
start fine, but when I look no process is running.

So I tried to start it manually and get teh same error

[root at tn1 init.d]# /usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf
500 OOPS: cannot open config file:/etc/vsftpd/vsftpd.conf

Anyone help?

Thanks, Scott

More information about the CentOS mailing list