[CentOS] Can't mount FAT32 partition

Dave Gutteridge dave at tokyocomedy.com
Thu Sep 1 02:10:04 UTC 2005

I've almost got this solved.

To make a long story of experimentation short, using the check disk 
utility inside Windows XP was not sufficient for ensuring the partition 
was in working order. I had to use my trusty Win98 boot disk, and run 
scandisk from there, where it fixed something to do with the directory 
structure. And then I went back to XP and ran checkdisk, where it then 
found cross linked files to repair. Not that I know what a cross linked 
file is, but my suspicion is that this all had something to do with the 
assault that Linux performed on my disk when I tried to mount the drive 
with the wrong settings.

So where I'm at now is that I can mount the drive from the command line 
like so:
[root at localhost ~]# mount /dev/hda1 /mnt/windows
... but only the root user can see it.

I want to be able to make it so that any user (which is almost always 
me, but sometimes I'm root, sometimes I'm just a user with the account 
"dave") can access the drive, and that it comes up in Gnome/Nautilus on 

Here is what I currently have in /etc/fstab:
/dev/hda1               /mnt/windows            vfat    
rw,uid=512,gid=1002 0 0

This also only seems to give root access. "dave" can not access the 
drive, and it does not show up in Gnome/Nautilus.

In this thread I got a lot of different variations on what that line 
should read, so I'm not sure which is the best for my situation.

How do I ensure universal read/write access to the disk for all users on 
my computer?


More information about the CentOS mailing list