[CentOS] Can't mount FAT32 partition

Rodrigo Barbosa rodrigob at suespammers.org
Thu Sep 1 19:34:44 UTC 2005

Hash: SHA1

On Thu, Sep 01, 2005 at 11:10:04AM +0900, Dave Gutteridge wrote:
> I've almost got this solved.
> To make a long story of experimentation short, using the check disk 
> utility inside Windows XP was not sufficient for ensuring the partition 
> was in working order. I had to use my trusty Win98 boot disk, and run 
> scandisk from there, where it fixed something to do with the directory 
> structure. And then I went back to XP and ran checkdisk, where it then 
> found cross linked files to repair. Not that I know what a cross linked 
> file is, but my suspicion is that this all had something to do with the 
> assault that Linux performed on my disk when I tried to mount the drive 
> with the wrong settings.
> So where I'm at now is that I can mount the drive from the command line 
> like so:
> [root at localhost ~]# mount /dev/hda1 /mnt/windows
> ... but only the root user can see it.
> I want to be able to make it so that any user (which is almost always 
> me, but sometimes I'm root, sometimes I'm just a user with the account 
> "dave") can access the drive, and that it comes up in Gnome/Nautilus on 
> boot.
> Here is what I currently have in /etc/fstab:
> /dev/hda1               /mnt/windows            vfat    
> rw,uid=512,gid=1002 0 0

Try adding umask=0


- -- 
Rodrigo Barbosa <rodrigob at suespammers.org>
"Quid quid Latine dictum sit, altum viditur"
"Be excellent to each other ..." - Bill & Ted (Wyld Stallyns)

Version: GnuPG v1.4.0 (GNU/Linux)


More information about the CentOS mailing list