[CentOS] Changing permissions on files that only exist during USB operation

Dave Gutteridge dave at tokyocomedy.com
Sat Sep 3 04:00:25 UTC 2005

A while back I got help in getting my Palm Pilot to connect to CentOS, 
and through the advice I got here I was able to successfully back up my 
files to the computer using the CentOS default Palm utility.

However, I now want to use JPilot to sync and install files. But when I 
attempt to sync through JPilot, I get the following error:
Syncing on device /dev/pilot
Press the Hotsync button now
pi_bind Invalid argument
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND

I searched on the net, and it would seem that this is because of a 
permissions problem with the /dev/pilot files. The advice I am following 
is here:

On this page the writer says that there are two ways to solve the 
problem - make the user the owner of the device, or make the device 
world writable. The author of the page says "making files (especially 
devices) world-writable should be avoided", but I think I'm not bothered 
either way.

In any case, when it comes to making the device owned by anyone or 
world-writable, I'm not sure how to proceed. Retracing some of the steps 
given tome on this list before, I can see that the relevant device files 
have the following permissions:
[root at localhost dev]# ls -l /dev/ttyUSB* /dev/pilot
lrwxrwxrwx  1 root root      7 Sep  3 11:57 /dev/pilot -> ttyUSB1
crw-rw----  1 root uucp 188, 0 Sep  3 11:57 /dev/ttyUSB0
crw-------  1 dave uucp 188, 1 Sep  3 11:57 /dev/ttyUSB1

So, I either want to give the user "dave" permission to use ttyUSB 1 and 
0, or make those files world-writable.

But where I hit a wall is that I can't figure out how to change the 
permissions on these files because they only appear when I hot sync the 
palm, a process that only lasts for a few  seconds, maybe 15 or 20 at 
the most, and also tends to get enough attention from the CPU to make it 
so it's tough to switch to the command line and enter in any commands in 
I tried the following, but the settings don't seem to stick for the next 
sync operation:
[root at localhost dev]# chown dave /dev/ttyUSB0 /dev/ttyUSB1

The advice I got last time on this list did speak about permissions, but 
unfortunately, I didn't pursue the issue because I thought the issue had 
been solved when I was able to make the basic connection at all to CentOS.

So my question is, how do I change permission on these temporarily 
existing device files to that JPilot will not return errors?


More information about the CentOS mailing list