[CentOS] LDAP/iptables

Sean O'Connell oconnell at soe.ucsd.edu
Tue Sep 6 05:13:59 UTC 2005

On Mon, 2005-09-05 at 21:29 -0400, Thomas E Dukes wrote:
> Hello Sean,
> I uncommented rootpw				secret
> commented out the sasl reference.  Still won't connect.  :-(
> I have been working on this for a week.  Its beating the heck out of me.
> Thanks for your help!!!!

OK. I took the slapd.conf that you had posted earlier, and I was able to
get it to work on a CentOS 4.1 box without too much trouble (clean up a
typo in the rootdn name and a cut and paste issue). I had to comment out
some stuff in /etc/openldap/ldap.conf. Something truly odd is going on
there. The fact that ldap is starting but not creating tcp sockets is
quite weird.

Have you tried rebooting? (I know, I know :) Sometimes system updates
can cause subtle issues from time to time. Maybe something is goofy with
the network on your machine. Have you been starting and stopping the
network service? Can you ping localhost? I have seen some linux boxes
(been a while, though) forget about how to talk to localhost and it
caused all sorts of weird behavior.  

As a shot in the dark, are you running with selinux enabled? It has
caused many a subtle problem in which a configuration that should "just
work" has failed to work. Try running setenforce 0 and then restarting
ldap. I run my machines with selinux=0 on the kernel line in grub.conf


More information about the CentOS mailing list