[CentOS] Yum thing

Henk van Lingen henkvl at cs.uu.nl
Tue Sep 6 12:38:22 UTC 2005

On Tue, Sep 06, 2005 at 08:08:16AM -0400, Ignacio Vazquez-Abrams wrote:
  > >   > 
  > >   > exclude=spamassassin perl-Mail-SpamAssassin
  > > 
  > >   Than it wants to do the one from [base]. After also excluding that,
  > >   it's out of options and doesn't want to downgrade anymore. Remains the
  > >   question why? Is yum using versionnumbers from somewhere else than what
  > >   'rpm -qip' shows?
  > Yes. It's using Provides and Obsoletes which -qi won't pick up on.

  Oke, so the problem is the 'Obsoletes' from the CentOS one, which is a
  'Requires' in my new version.

  I'll have a look why RedHat makes it one package whereas
  spamassassin.org's specfile makes it two.


Henk van Lingen, Systems & Network Administrator              (o-      -+
Dept. of Computer Science, Utrecht University.                /\        |
phone: +31-30-2535278                                        v_/_
http://henk.vanlingen.net/             http://www.tuxtown.net/netiquette/

More information about the CentOS mailing list