[CentOS] Why is yum not liked by some?

Craig White craigwhite at azapple.com
Thu Sep 8 04:54:55 UTC 2005

On Thu, 2005-09-08 at 11:03 +0900, Dave Gutteridge wrote:
> As for finding out what my "baseurl" is, I'm not sure I'm doing the 
> right thing. I tried the command suggested, and I got the following result:
> [root at localhost ~]# grep http /etc/yum.repos.d/fedora.repo
> grep: /etc/yum.repos.d/fedora.repo: No such file or directory
> So I thought I'd look in my repos directory, but none of the files there 
> are for fedora or freshrpms.
> [root at localhost ~]# cd /etc/yum.repos.d
> [root at localhost yum.repos.d]# ls
> CentOS-Base.repo  kbsingh-CentOS-Extras.repo  output.txt
> dag.repo          kbsingh-CentOS-Misc.repo
sorry - I should have been more explicit - I guess I thought you would
figure it out from my hint since I don't have freshrpm's in my repos
(remember, I don't use yum but use smartpm instead)...

# grep http /etc/yum.repos.d/*

which spits them all out - or a more specific grep for freshrpms out of
this list...
# grep http /etc/yum.repos.d/* |grep freshrpms

which of course means that I don't have freshrpms configured.

and somewhere I missed the part of the thread that caused whomever to
ask you which base url you are using for freshrpms.
> Also, based on what was suggested to me in this thread, I tried running 
> 'shutdown now -Fr', and on reboot, the system did some kind of check, 
> but returned no errors or anything. It kind of flickered to my GUI log 
> in screen before I could see anything come of it.
well - it hurt nothing to check
> Then I tried running fsck on var as was also suggested. But that 
> produced some kind of error:
> [root at localhost ~]# fsck /var
> fsck 1.35 (28-Feb-2004)
> e2fsck 1.35 (28-Feb-2004)
> fsck.ext2: Is a directory while trying to open /var
> The superblock could not be read or does not describe a correct ext2
> filesystem.  If the device is valid and it really contains an ext2
> filesystem (and not swap or ufs or something else), then the superblock
> is corrupt, and you might try running e2fsck with an alternate superblock:
>     e2fsck -b 8193 <device>
fsck should only check NON-MOUNTED partitions anyway - since you
said /var isn't on it's own partition, you really have no opportunity to
fsck /var except to 'shutdown now -Fr'
> And all this reminded me, I have a little extra space on my disk which 
> is not partitioned:
> Disk /dev/hdb: 30.7 GB, 30738677760 bytes
> 255 heads, 63 sectors/track, 3737 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Device Boot      Start         End      Blocks   Id  System
> /dev/hdb1   *           1        3644    29270398+  83  Linux
> /dev/hdb2            3645        3737      747022+   f  W95 Ext'd (LBA)
> Should I turn that into a Linux swap, and might that help with this YUM 
> issue? A guy on this list gave me some instructions for doing that, but 
> I got this error from fdisk:
> [root at localhost yum.repos.d]# fdisk /dev/hdb
> The number of cylinders for this disk is set to 3737.
> There is nothing wrong with that, but this is larger than 1024,
> and could in certain setups cause problems with:
> 1) software that runs at boot time (e.g., old versions of LILO)
> 2) booting and partitioning software from other OSs
>    (e.g., DOS FDISK, OS/2 FDISK)
> Command (m for help): t
> Partition number (1-5): 2
> Hex code (type L to list codes): 82
> You cannot change a partition into an extended one or vice versa
if you are sure that hdb2 has nothing of value on it, all you need to do
is to delete it and then create the new swap partition. fdisk is
complaining that it can't convert an extended dos partition. Delete it
and it's gone. How much ram do you have in that computer? I would have
created a separate /boot (approx 100 megabytes) and a separate swap
partition (probably 2 * the amount of ram depending upon how much ram).
You might simply be running out of memory - swap is sort of needed for
systems with less than 512 Mb of real ram - especially one running
desktop apps.


More information about the CentOS mailing list