[CentOS] What's going on with my Linux Swap?

Matt Hyclak hyclak at math.ohiou.edu
Thu Sep 8 13:39:28 UTC 2005

On Thu, Sep 08, 2005 at 10:32:10PM +0900, Dave Gutteridge enlightened us:
> I've tried to create a Linux swap file, but when I run fdisk, it looks 
> like this:
>   Device Boot      Start         End      Blocks   Id  System
> /dev/hdb1   *           1        3644    29270398+  83  Linux
> /dev/hdb2            3645        3737      747022+   f  W95 Ext'd (LBA)
> /dev/hdb5            3645        3737      746991   82  Linux swap
> Why is this W95 partition existing in the same place as my Linux swap? I 
> would have thought they'd be incompatible.
> Can my Linux OS use this Linux swap?
> Does this need cleaning up, and if so how?

It looks like it is some sort of extended partition. DOS disklabels can only
have 4 partitions (primary), so to get around that you can create a primary
partition as type extended, which can contain more partitions (up to 12, I

On my system, the extended partition is type 5, on yours it's type f. I'm
not sure it's hurting anything, but to be on the safe side, I'd probably
delete partitions 5 and 2, and just create a primary partition of type 82
(Linux swap).

In a related note, does your system have no other swap enabled at all? That
could explain your yum-lockup problems. Yum is very memory intensive, if you
starve it and it has no swap to go to, it probably will lock up. :-) 


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20050908/094328ec/attachment.bin

More information about the CentOS mailing list