[CentOS] What's going on with my Linux Swap? [SOLVED]

Matt Hyclak hyclak at math.ohiou.edu
Fri Sep 9 16:17:36 UTC 2005

On Sat, Sep 10, 2005 at 01:12:17AM +0900, Dave Gutteridge enlightened us:
> I realized what went wrong with the earlier commands.
> If I do fdisk, it looks like this:
>   Device Boot      Start         End      Blocks   Id  System
> /dev/hdb1   *           1        3644    29270398+  83  Linux
> /dev/hdb2            3645        3737      747022+   f  W95 Ext'd (LBA)
> /dev/hdb5            3645        3737      746991   82  Linux swap
> I don't understand why it still says W95 Ext there, as I thought I 
> deleted that.
> But anyway, it seems my swap is on hdb5, not hdb2. If I run the 
> following commands:
> mkswap /dev/hdb5
> swapon /dev/hdb5
> And add this to your /etc/fstab: 
>  /dev/hdb5    swap    swap    defaults   0 0
> then it works.
> I hope it's okay to run it this way.

Yeah, it doesn't make a big difference. I just noticed this morning another
Linux machine I have that is using a type f (W95 Ext) extended partition
instead of type 5. Since you only have 2 partitions, you don't need the
extended partition, but it also isn't hurting anything.

If you run the "free" command, you should see something after Swap: that is
greater than 0. 

As I said before, it will probably help the lock-up situation if you didn't
actually have any swap before.


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263

More information about the CentOS mailing list