[CentOS] NFSv4 "Missing" Data on Clients

Jason McCormick jason at devrandom.org
Sun Sep 11 05:22:51 UTC 2005

  Hello all.  I converted my server from Fedora Core 3 to CentOS 4.1 and I've 
been slogging unsuccessfully through an NFSv4 problem.  I'm using the same 
configuration for NFS that I had in place on FC3 that worked.  On the server, 
I have the following data structure:


Each is a separate ext3 filesystem mounted with rw,acl.  /etc/exports presents 
all of these filesystems properly:

# exportfs -v

All the the appropriate services are running (portmap, nfs, rpcidmapd).  I've 
tried this with and without iptables enabled so I've ruled out firewall 
issues.  When I mount the filesystem on the client, none of the "sub" 
mountpoints shows its content:

# mount -t nfs4 server:/ /mnt/server
# ls /mnt/server
archive  lost+found  music  pictures
# ls /mnt/server/archive

Except that there's 15G of data in /data/archive on the server.  File 
operations in /data that don't traverse the server-side mountpoints work fine 
(i.e. I've created /data/foo and performed reads and writes in there on the 
client).  I know that this setup worked in Fedora 3 so I'm unable to account 
for the operational differences.  Anyone have any thoughts?

- Jason

More information about the CentOS mailing list