[CentOS] x86_64 Question

Alex White ethericalzen at gmail.com
Mon Sep 12 17:05:51 UTC 2005

Hello All,

It's time for my stupid question of the year. I just swapped over to 
an Athlon64 proc. I went to compile a src rpm and it bombs out. Now, 
rather than have anyone troubleshoot this and add noise to the list, 
I'm fairly certain what it's been answered before by someone. I 
tried google and never did see a true answer. what I do see is stuff 
about mozilla mostly and associated plugins. This isn't solving my 

Is there some linkage anyone can pass to me that tells me (not 
necessarily step by step) what options to pass to rpmbuild if I want 
to build a 32-bit app on the athlon64? I assumed it was --target 
i686 or somethin' similar but all of the options I've tried with 
target result in the same failure. Namely:

checking for C compiler default output... configure: error: C 
compiler cannot create executables

Or I get the following when passing no options to rpmbuild at all 
other than building the binary:

Invalid configuration `x86_64-unknown-linux-gnu': machine 
`x86_64-unknown' not recognized

I've already managed to build gaim 1.5.0 (as a test) and it builds 
and installs fine. So I'm confuzzled. I'm sure it's something 
hugenormously ignorant and dumb on my part. Englighten me please.

CentOS-4 (current on all updates)


Alex White

More information about the CentOS mailing list