[CentOS] Boot/init problem with IBM Netfinity 4500

Will McDonald wmcdonald at gmail.com
Fri Sep 16 11:43:15 UTC 2005

I hope the CentOS people don't mind me cross-posting for their input.

I've just done a clean, text-mode minimal  WBEL4 install on an IBM
Netfinity 4500, essentially the same hardware as an xSeries 340.

The install went fine but now the box will boot, run through the
initrd init sequence, perform its switchroot then hang here...

SELinux: Initializing.
SELinux: Starting in permissive mode

I don't think it's an SELinux issue though, booting with selinux=0 the
system just hangs after the switchroot because it's not initializing
SELinux at all. It's what's coming next that's causing the problem.

On a working system (different hardware) the next stage is INIT...

INIT: version 2.85 booting

I've tried adding some debug echo lines into rc.sysinit incase it's
something in there causing the problem but the init process doesn't
appear to be getting that far. So, somewhere between the initrd's
switchroot and spawning INIT something's broke.

It'll boot into rescue mount and I can chroot into the root filesystem
and everything in there seems to be as it should. I've tried booting
with selinux=0, noapic and noprobe with no change.

Where next? All suggestions appreciated.


More information about the CentOS mailing list