[CentOS] Update/upgrade paths?

Dave Laird dlaird at kharma.net
Sun Sep 18 22:31:39 UTC 2005

Good afternoon, Sean...

On Sunday 18 September 2005 1:39 pm, Sean O'Connell wrote:

> If you are willing to do kickstarts, then, yes. you can do this. Add a
> reinstall entry to your /etc/grub.conf using vnc (you connect to
> myserver:1)
> title Reinstall System
>         kernel /vmlinuz-reinstall ks=<URL>/server-reinstall.cfg vnc
>         initrd /initrd-reinstall.img
> where vmlinuz-reinstall and intrd-reinstall.img are the vmlinuz and
> initrd.img from the pxe subdirectory of os/<arch>/images/pxeboot that
> you need to download and drop in /boot (the above assumes /boot is its
> own partition otherwise you'll need /boot/vm..). There are a bunch of
> issues with doing this:
> 1) are you comfortable with kickstart?
> 2) are the machines using static addressing or dhcp? if static, then
> you'll have to add a few command line parameters:
> ip=w.x.y.z netmask= gateway=w.x.y.1 dns=w.x.y.2
> 3) you'll probably want to add a vncpassword=xxxxx flag as well
> You'll probably want to play with a local machine first (and make sure
> someone is there to push a power button :).
> Hope that helps,

It did work incredibly well to a point, despite my fumble-fingered
approach to typing in the commands, as given. I *should* have listened to
your advice of trying it locally before taking a shot at it remotely,
though, because things froze because of a bad vmlinuz-reinstall location.
However, I had someone at the remote site who read me the errors, and I
fixed the problem. 

The situation that originated this query took place recently when I tried
to do a CD-based upgrade from 3.3 to 4.1, and although the install medium
did search for previous instances of CentOS, it never found one (it was
there, really!) and continued to try reinstalling the entire OS. I finally
resorted to telling the installation to only format the /boot partition
and *not* format the / partition, which seems to have worked, as it
overwrote only those applications that had been upgraded/changed and saved
all the configuration files. 

However, I think once I get the knack of performing remote upgrades, I'll
be eventually doing more of them. 

Thanks for everyone's help with this. If anyone else has encountered the
problem I met going from 3.3 -> 4.1, I'd like to hear about it, as well.
The only reasons I am eager to upgrade to 4.1, as I alluded to earlier, is
the more recent 4.1 kernel, expanded management utility applications, and
x.org rather than XFree86. 

I have not had *any* stability or security issues in 3.3 at all. Much to
the contrary, it has been more stable than anything else I have tried in
the recent past, including various other distributions too numerous to
mention. I've even begun using a highly-modified workstation configuration
at both my office and home, and am reasonably content with that, as well,
with only a few minor exceptions. ;-) 

Dave Laird (Dave at kharma.net)
The Used Kharma Lot / The Phoenix Project 
An automatic & random fortune for the Minute:    
At these prices, I lose money -- but I make it up in volume.
		-- Peter G. Alaquon

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20050918/f751ac39/attachment.bin

More information about the CentOS mailing list