[CentOS] Just can't get sound working in Firefox [SOLVED]

Ignacio Vazquez-Abrams ivazquez at ivazquez.net
Wed Sep 21 16:35:35 UTC 2005

On Wed, 2005-09-21 at 21:32 +0900, Dave Gutteridge wrote:
> > 
> > Save the following as ~/.asoundrc and kill all apps using sound:
> Holy smoke, that worked like a charm! Worked so well in fact that I'm
> kind of stunned.
> What the heck happened? What was that magical file? Why was it not there
> before and how was it so obvious that was the problem?
> I'm keen to learn!

Some soundcards support hardware mixing, some don't. If the card doesn't
then subsequent requests to open the audio device will be denied. The
file provided activates the dmix ALSA plugin which does software mixing
instead. dmix will always allow multiple apps to open the audio device
since it does the mixing itself.

It's not there by default since software mixing does use some CPU power,
and not all cards need it.

Ignacio Vazquez-Abrams <ivazquez at ivazquez.net>

gpg --keyserver hkp://subkeys.pgp.net --recv-key 38028b72
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20050921/71dec6f7/attachment.bin

More information about the CentOS mailing list