[CentOS] MythTV on Centos 4

Kirk Bocek t004 at kbocek.com
Wed Sep 28 16:48:41 UTC 2005

Aleksandar Milivojevic wrote:
> Quoting Kirk Bocek <t004 at kbocek.com>:
>> That's what I thought too. I had wanted to run i386 for compatibility. 
>> But as I mentioned to Brian J. Smith off-list, both KnoppMyth and 
>> CentoOS4.1 i386 hung when booting off of the install disk. Whereas 
>> CentoOS4.1 x86_64 installed without complaint.
>> Can anyone come up with a reason x86_64 would boot but i386 wouldn't?
> Could be hole lot of things.  Most likely something is weird with your 
> BIOS or
> motherboard.  The CPU as such shouldn't be a problem.  When you say "hung",
> does it load the kernel and initrd images at all?  Does the kernel 
> starts?  Are
> you getting kernel panic?  Is initrd stuff freaking out?  Installer 
> hungs?  They
> are all on different levels, and might point to different things going 
> wrong.

It always happened fairly far into the boot process. KnoppMyth would hang just after 
"Detecting Hardware". Sometimes (but not always) it would give a kernel panic. I 
tried the 'failsafe' boot with the same result. I'd have to reboot CentOS to see 
exactly where it was happening but CentOS would always panic with a whole bunch of 
register dumps and so forth that would scroll off the screen.

x86_64 had been rock-solid for almost a week now.


More information about the CentOS mailing list