[CentOS] Warm reboot failure

Fri Apr 7 15:41:59 UTC 2006
Tarun Reddy <treddy at rallydev.com>

I recently bought a new Compaq Presario sr1710nx with 64-bit Sempron  
and last week installed Centos 4.3 64-bit on it.

Worked like a champ until I attempted a reboot (using "init 6") and  
the computer hung after finishing the shutdown. Rebooting from cold  
worked, but without a warm reboot I was hesitant to use Centos. Since  
FC5 (64-bit as well) came out recently, I tried it and warm reboots  
work great.

So it would seem that it is a kernel/driver issue, but I have no idea  
where to begin. Also I'm not if additional grub boot parameters might  

I won't be in front of the machine until this weekend, but since  
everyone else will be gone by them, I'd thought I'd ask you guys if  
you had any ideas. I really would like to get back the package  
stability of Centos. Fedora 5's updates are driving me nuts (too  
many, too often and too major).

Any suggestions? (I'm going to try 32-bit Centos this weekend first)

Thanks ahead of time,