[CentOS] Several problems upgrading CentOS 4.1 to 4.3

Sun Apr 9 05:43:18 UTC 2006
Ale Feltes Quenhan <ale at roshka.com.py>

I had a CentOS 4.1 installation (LVM over RAID1), and tried to do an 
update to
the 4.3 release.
Nothing too fancy, I did all the partitions with the graphical installer 
for the
4.1 Version.
First, the installer did not find the previos installation, then I tried 
the "upgradeany" option to the kernel, and from there the update ran 
with no problem.
When the boot loader section came, the setup was not able to find the 
working grub configuration, and the "update boot loader" option was 
so I marked the "new boot loader configuration" (don't remember the 
exact string.
Then the installation process ended, and I did reboot.
The "classic" "Error 15: File not found", from grub came. The 
description line
was indeed, for the 2.6.9-34 (centos 4.3's relase), but I could not boot the
I went into the "linux rescue" and from there, I started to find out 
some more
weird stuff.
First, the kernel package was not installed correctly, the files. 
/boot/* and
/lib/modules/* weren't there, there was no entry on the rpm database, in 
the only probe that the kernel was "installed" was the grub entry.
I tried to rebuild my old grub configuration, and boot with the previous 
version I had. (The rescue disk, did not let me mount the cdrom, and I was
without Internet to find out how to enable de /dev entry to acomplish 
the task).
With the old kernel config, I could start my server, but I could not 
login from
the console (tty*).
Then I had to reboot  in single mode, and from there perform the kernel
installation from the 4.3's cdrom.

/var/log/messages had this line for every login attempt:
login [1234]: Module unknown.

As this is a production server, I checked for all the services (ldap, 
mysql, apache, etc.) and there where all working fine.
I could log in from sshd without any problem (besides the bunch I'm writing
here of course).
Finally, when I checked on all the services and  the console login
problem, the rest was working as before.
I went then to the "yum check-update", and found some "pam-*" update, so I
did the corresponding "yum update".
After pam's update, I could login again from the console, by the way 
tasks weren't working either, when console login was not working.
That is not the end of this Crypt's Tale :(
Now I have the system, running 4.3, yum does not report any update, but 
I have
several duplicated rpm installed. :(
I'm willing to try all this again, in a VMware, just to convince myself 
that I'm
not crazy, and that ghosts does not exist :)

upgrade.log has several lines like this:
Upgrading kernel-2.6.9-34.EL.i686.
error: %pre(kernel-2.6.9-34.EL.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping kernel-2.6.9-34.EL
Upgrading kernel-smp-2.6.9-34.EL.i686.
error: %pre(kernel-smp-2.6.9-34.EL.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping kernel-smp-2.6.9-34.EL

where the pre-install script fail, but how come the installer did not 
any problem during installation?

I'm not a newbie, I have quite a while working with linux, and I just 
want to
aware people who are going to perform an update, skipping some version in
between or perhaps moving to 4.3 to be very carefull in the process.
I think this was a experience that was worth telling and researching to 
find out
what really happend.

Best Regards