[CentOS] CentOS 4.3 occasionally locking up accessing IDE drive

Mon Apr 3 17:01:11 UTC 2006
Bart Schaefer <barton.schaefer at gmail.com>

On 4/2/06, William L. Maltby <BillsCentOS at triad.rr.com> wrote:
> Well, then it sounds like it's isolated on that drive.

I suppose it could actually be a problem elsewhere in the system that
just happens to be triggered by IDE traffic load, but I have no idea
how to diagnose that -- the system locks up so hard that I can't
examine console output, and there's nothing in dmesg or any of the
logs after the reboot.

> Did you do the sfdisk -l to see if the geometry stored on-disk matches BIOS

Yeah, that all looks OK.

> My next suggestion is to see if the problem can be reproduced...

I haven't had a chance to try anything since the other night, but it
was consistently happening whenever I ran the equivalent of
"badblocks" on it with the system booted in multi-user mode.  Hmm ...
IRQ conflict?

> HOLD THE PHONE! One other thing to consider/try! Have you put this drive on
> another IDE port and tried all the same things?

> Since we are passed the
> "easy" answers, we must include the "obvious" too. Is the jumpering
> correct for how it is installed?

Yes, I checked that.

> 1) Is the MB one that uses "cable select"?

Almost certainly.

> Is the jumper appropriately  CS/MAST/SLAVE? Is it on a cable
> with another drive or CD? Are they jumpered appropriately CS/MST/SLAVE?

It's the slave on the same cable with the other Maxtor which is
working correctly.

> Are they active when the problems are detected (since the diags shows no
> prob and I assume nothing else runs then)?

The problem has occurred both with and without the other drive active.
 In fact my first thought was that the problem was related to having
both drives active, but that proved not to be the case.

> Also, don assume that new=good. New eqpt has "shakedown cruise" because
> it is inherently less reliable that tried and true stuff.

The system had been operating properly for several weeks before I
hooked up these drives, and was [supposedly] throroughly tested by the
manufacturer before it was shipped to me.

> Last ditch effort to prove drive one way or the other: put it into
> another unit and try similar operations

Yeah, next on the list when I have a chance ...