[CentOS] SATA Raid 5 and losing a drive

Tue Apr 11 17:47:14 UTC 2006
Andy Green <andy at warmcat.com>

Joshua Baker-LePain wrote:

> Did you try doing any I/O to the array?  In my limited experience with 
> software RAID, it won't notice a drive missing until it tries to do 
> something with said drive.

Yes I did do this, I copied a file to the mountpoint and did a sync. 

Only at the end of the shutdown did we see some SCSI IO errors, it tried 
a few times to flush and then gave up and completed the reboot.

> To really test it, I'd disconnect the drive while you have something 
> disk intensive running.  I like 
> <http://people.redhat.com/dledford/memtest.html>, which unpacks and then 
> diffs multiple copies of the Linux source tree.  It'll have the system 
> stressed *and* let you know if there any problems with the array running 
> in degraded mode.

That'd for sure stress it :-)  But if a cable falls out or a drive 
shoots out of the box high into the night sky, I would expect to hear 
about it at least from the logs next time I tried to write one byte.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 4492 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20060411/d4ddac42/attachment-0005.bin>