[CentOS] Re: RPMforge mplayerplug-in seems to be locking up my sound device

Mon Apr 17 05:30:06 UTC 2006
Bart Schaefer <barton.schaefer at gmail.com>

[Sorry for the multiple self-followups.  This should be the last one for a bit.]

On 4/16/06, Bart Schaefer <barton.schaefer at gmail.com> wrote:
> On 4/16/06, Bart Schaefer <barton.schaefer at gmail.com> wrote:
> > installed was mplayerplug-in-3.25-1.el4.rf ... now any time I
> > attempt to view CNN video, my sound device locks up
> Some additional information:  The sound device is only stuck because
> mplayer itself is stuck.

I tried the plugin again and found that four copies of mplayer are
being started up.  One of those four appears to be in an infinite loop
(strace shows nothing, but cputime increases rapidly).  If I kill that
runaway process, one of the other three also dies -- and one of the
remaining two plays the video normally.

I can repeat this several times (start loading a new video, kill the
runaway, watch the video) but eventually that hangs as well.  At that
point killing all mplayer instances and running
system-config-soundcard gives me:

aplay: pcm_write:1115: write error: Input/output error

Even unloading and reloading all the sound-related kernel modules is
not sufficient to revive the device at that point.  Google for that
error message only finds threads about conflicts with the intel8x0m
modem driver, but I don't have a modem and that modem driver is not

I've tried downloading/compiling/modprobe-ing the nvsound driver from
nVidia's website, but that's an OSS driver rather than ALSA (as I
understand the snd_intel8x0 driver to be).  Is there something I need
to do to switch over to OSS? Or is that entirely the wrong thing to be
looking at ...?