[CentOS] Re: Problems Formatting /boot With CentOS 4.3 on a DL360 G3

Mon Apr 17 22:23:57 UTC 2006
Canaris <tiahino at gmail.com>

On 4/14/06, Canaris <tiahino at gmail.com> wrote:
> On 3/31/06, Brian Hill <ncturnal.forums at gmail.com> wrote:
> > I'm having the exact same problem on a DL360 G3 as well with CentOS 4.3.
> >
> >  <hkclark at ...> writes:
> >
> > >When it gets to "Formatting the /boot file system..." it
> > > quickly moves up to about 90-95% complete, and then it totally locks
> > > up... the mouse quits moving, the animated cursor locks up...
> > > everything.
> Same here - first with an old Compaq laptop and then with several
> Intel ISP 1100 boxes, which I used to install with all possible
> versions without a single problem.
> Thanks,

Hi All,

After spending a couple of days I am able to provide more details to
the problem.
I think I've found a workaround - at least I am able to install ISP
1100 boxes now.
(I've tried several boxes, so hardware failure is out of the question,
at least in this part it is consistent :)

1. I am doing the install using pxelinux and nfs over the serial
console. My typical install on this system makes sw raid1 from hda1
and hdb1 for /boot and the rest of file system reside as lv's on the
second sw raid (hda2 and hdb2).
2. After attempting to install C4.3 I've tried to revert back to C4.2
- it would hang in exactly same point. Something makes me think c4.3
wrote something onto the hard drives which couldn't be swallowed by
the install process... Tried to install just the workstation with the
default partition layout picked up by anaconda - it worked once, but
failed later.
3. Tried to wipe the hard drives with zeroes - first just the
partition table, then the whole hard drive - does not seem to help -
it MAY install, but is very inconsistent.
Also tried different boot options - noapic, acpi=off, apm=off, nousb,
nousbstorage - none of them seems to have any effect on the outcome.
4. After several consecutive hangs added the VGA card to the box still
attempting to install using the serial port as a console. It still
freezes, or I should rather say the install process freezes, because
the system is responding to keyboard input. At this point I have more
information - on the fifth screen there is an output from mkfs
command, and the last message is 'Writing superblocks and filesystem
accounting information'. As I've used serial port as the console, I
don't have a shell on the second screen, so I can't get more info and
proceed to the next step.
5. Attempted to install using VGA as a console. It appeared to freeze
at the same point, but then I switch over to the shell and start
poking around, like cat /proc/mdstat, top and other commands (like
while true; do clear; cat /proc/mdstat; sleep 2; done). After a minute
or so mkfs wakes up and the install process continues.
6. I don't believe my eyes and try to re-install several times. It
works now even without me touching anything. Then I try to install
with the serial console (still having the VGA card connected) - it
still works.
7. Remove the VGA card, install purely through the serial console - it
fails again. Re-insert VGA card, repeat step 5 - success.
8. Get another ISP 1100 box, repeat steps 5-7, observe a consistent
behaviour, call it a workaround.

Hope this would help to somebody who understands better the
interaction of anaconda, swraid and lvm to fix the problem, because
for some reason I believe it is related to some race condition.

Have a great day,