[CentOS] Postfix /etc/aliases problem

Sun Apr 30 18:42:04 UTC 2006
Jay Leafey <jay.leafey at mindless.com>

Damien Hull wrote:
> Hash: SHA1
> Here's what I have from log watch.
>    Database files are not up-to-date (propably rehash is needed):
>    /etc/aliases : 16 Time(s)
> Here's what I get from /var/log/maillog
>   Apr 29 20:37:22 00304842f27e postfix/local[25980]: warning: database
>   /etc/aliase s.db is older than source file /etc/aliases
> Here's what I'm using
> 1. CentOS 4.3
> 2. Postfix as my MTA
> 3. Sendmail is still in the system
> 4. I used "system-switch-mail" to switch from sendmail to postfix.
> Here's what I've done
> 1. newaliases
> 2. postalias aliases
> 3. postmap aliases
> When I ran postmap I got errors. When I ran postalias it didn't give me
> any errors. However, I'm not sure it's working because I still get the
> database error in my logs.

First off, make sure Postfix is looking for the alias files where you THINK they are looking.  Use the 'postconf' command to make 
sure it's looking in the right place.  For example:

> [root at mail1 root]# postconf alias_maps
> alias_maps = hash:/etc/postfix/aliases
> [root at mail1 root]# postconf alias_database
> alias_database = hash:/etc/postfix/aliases

If both of these aren't pointing to your aliases file in /etc, you can change them to do so using postconf:

postconf -e "alias_maps = hash:/etc/aliases"
postconf -e "alias_database = hash:/etc/aliases"

Then run 'newaliases' to rebuild the aliases.db file from the text file.

Hope that helps!
Jay Leafey - Memphis, TN
jay.leafey at mindless.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5322 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20060430/47c39d91/attachment-0005.bin>