[CentOS] CentOS 4.4 and ACLs

Thu Dec 7 15:49:08 UTC 2006
Ian Bonnycastle <ibonny at jhu.edu>

     Hey all,

     I'm using CentOS 4.4, and want to start doing some work with ACLs 
(getfacl/setfacl). Unfourtunately, no matter what I do, I get the same 
error over and over again:

     setfacl: <filename>: Operation not supported

     I've tried enabling/disabling the acl and xattr modes on my root 
partition (the one I'm working on), I've tried moving the file to other 
directories, rebooting the system after I make the changes... nothing.

     Right now, the system is set up as follows:


       LABEL=/                 /                       ext3,acl    defaults 
1 1

     % mount

       /dev/sda5 on / type ext3,acl (rw)

     Should I have a particular kernel module loaded? getfacl seems to work 
fine, but it may be deferring to the lower-level chmod permissions that 
are already there. If there is a kernel module to load, I can't tell what 
it should be, since there are none that have "acl" in their names under 
/lib/modules/<kernel version>.

     Please help!


Ian Bonnycastle
Systems Administrator
Center for Language and Speech Processing
Johns Hopkins University