[CentOS] Help With Installation to USB Stick

Thu Dec 14 08:54:36 UTC 2006
Pierre Bourgin <pierre.bourgin at arteris.com>


It sounds like you forgot to label your / partition (/dev/sda2) as "/".

As a workaround, interrupt the grub loader and edit the boot command line
   kernel /vmlinuz-2.6.9-42.EL ro root=LABEL=/ rhgb quiet
   kernel /vmlinuz-2.6.9-42.EL ro root=/dev/sda2 rhgb quiet

you should then be abble to boot the kernel and get a minimal shell, but 
probably failed to mount "/" ie finish the boot process : /etc/fstab may 
also mention "LABEL=/" instead of "/dev/sda2" for / FS.

To fix it, 2 solutions:

* once booted, (mount and) modify /boot/grub/grub.conf to modify the kernel 
boot parameters as did to boot and also the /etc/fstab.

* or label your root partition as "/" to match the kernel options in grub.
the command to do it is:
   e2label /dev/sda2 "/"
I'm not sure you can do it on your running system (ie /dev/sda2 mounted), 
you should use a rescue system to do it.

Hope this help,

Pierre Bourgin

Mark Rose a écrit :
> Recently, I was able to create a workable Centos 4.4 "Live USB" on my 1G
> Lexar Firefly pendrive using the steps in
> http://linux.web.psi.ch/livecd/usbdisk.html. At the moment, it is doing its
> job, so I probably won't focus too much more on it. One thing that is
> annoying, although doesn't cause a problem is that on powerdown and reboot,
> the cd rom drive ejects - of course, there is no CD in it!
> My ultimate goal is to get a standard, updatable 4.4 install onto my 4G
> Firefly, I am at a loss as to why I get the following errors:
> ***************************************
> Booting 'CentOS-4 i386 (2.6.9-42.EL)'
> root (hd0,0)
> Filesystem type is ext2fs, partition type 0x83
> kernel /vmlinuz-2.6.9-42.EL ro root=LABEL=/ rhgb quiet
> [Linux-bzImage, setup=0x1400, size=0x16dd65]
> initrd /initrd-2.6.9-42.EL.img
> [Linux-initrd @ 0x1fefe000, 0x612ef bytes]
> Uncompressing Linux... Ok, booting the kernel.
> Red Hat nash version starting
> mkrootdev: label / not found
> mount: error 2 mounting ext3
> mount: error 2 mounting none
> switchroot: mount failed: 22
> umount /initrd/dev failed: 2
> Kernel panic - not syncing: Attempted to kill init!
> ***************************************
> This is what I did:
> - installed CentOS 4.4 from CDs using "expert mode"
> - grub bootloader
> - /dev/sda1 mounted on /boot  100M
> - /dev/sda2 mounted on /          3.9G
> - no swap
> - server install (w/gdm)
> It was suggested that I may be having an issue with USB drivers not getting installed, so I ran mkinitrd including them.  I also uncompressed initrd.gz and tried to add them manually - I had no luck with either method.
> Since I am by no means a Linux expert (my background is in data and voice networking), any and all suggestions and URLs will be appreciated!
> Mark
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos