[CentOS] 4.2 install w/250GB raid arrays won't boot

Fri Feb 10 15:15:00 UTC 2006
rado <rado at rivers-bend.com>


raid 1 arrays: I already have 2 systems running this same raid1 config.
1 sys has 2 120 gb
1 sys has 1 120gb and 1 200gb but matching the raid partitions

this system here that is giving me fits right now has 1 250gb and 1
200gb.  I tried it w/a new 250 gb for the 2nd drive but the  same
results. Will not boot.

in druid, when I am config. the raid arrays, I always create the
boot partitions in hda1 and hdc1 and make them primary...maybe I am
doing wrong by giving them 200mb instead of 100mb but I do it in the
other 2 raided systems I run and no probs.

I then create the sys partitions: hda2 and hdc2

lastly, the swaps as hda3 and hdc3

grub: here's what I did/do and here's the results:

linux rescue
chroot /mnt/sysimage

/sbin/grub-install /dev/hda   ...the complaint/result:
/dev/md0 does not have any corresponding drive

I have tried: /sbin/grub-install /dev/hda (as a stab in the dark)
it gives the same result

/sbin/grub-install /dev/hdc also produces the same result

I have done the following:

dropped to grub

# grub
grub> root (hd0,0)
        result: Filesystem type is ext2fs, partition type 0xfd
grub> setup (hd0,0)
        Checking if: 
                "/boot/grub/stage1" exists ....no
                "/grub/stage1" exists...yes
                "/grub/stage2" exists...yes
                "/grub/e2fs_stage1_5" exists...yes
        "embed /grub/e2fs_stage1_5 (hd0,0)"...failed(this is not fatal)
        "embed /grub/e2fs_stage1_5 (hd0,0)"...failed(this is not fatal)
        "install /grub/stage1 (hd0,0) /grub/stage2
p /grub/grub.conf"...suceeded

I messed w/cmos...oh, enable/disable S.M.A.R.T. Drive....bypassing cd-
rom drive...so hd0 be the first boot...nothing changes...just "DISK BOOT


John Rise