[CentOS] OT: Local Mirror problems, wrong paths to RPMs with yum update

Fri Feb 17 17:32:06 UTC 2006
James Pifer <jep at obrien-pifer.com>

This week I set up a local mirror for a few dists, including Centos 4.0
and 4.2, and Fedora Core 3 and 4. I'm using a script called yum-pull.
For the most part I really like the script, it automates the setup of
your mirrors and tries a bunch of different mirrors when it goes out to
get updates, if it fails on one it tries another. It uses the usual
suspects, createrepo and repoview, among others.

That being said I have it all setup, but I have the following problem.
For some reason the paths are not always right when you run yum update
from a workstation. I'm installing a fresh copy of centos 4.2 right now
so I can test the centos mirror, but I definitely have problems with my
FC3 and 4 ones.

One example, if I include atrpms in my repo file, it's looking for the
RPMs in this directory:
BUT it should be looking here:

Can anyone tell me where this is screwed up at?

The directory structure looks like this:



I just tried my centos4.2 mirror on the new test install and it worked
ok. Still, any help understanding this is appreciated. I did some
googling on createrepo but have yet to find my answer.