[CentOS] Assistance requested

Mon Feb 27 03:18:57 UTC 2006
Sam Drinkard <sam at wa4phy.net>

Hi List,

    I've run into a library problem I believe might be related to the
portland group compiler, and / or the libs on CentOS.  Essentially what
is happening is the primary executable I'm trying to run is failing
under mpi.  Here's the output from the command (which would be the same
as the script calling it)

$ /usr/local/mpich/bin/mpirun -machinefile machines.LINUX -np
2 ./wrf.exe
/home/sam/WRFV2/run/./wrf.exe: /usr/pgi/linux86-64/6.0/lib/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /lib64/tls/librt.so.1)

Oddly enough, this same kernel environment works quite well with a
previous version of the WRF code, but fails miserably with this update..
The compiler which bullt the old package built the new one too.  The
current package is still running by setting "LD_ASSUME_KERNEL=2.4.2"
which was suggested by Maze, back some months ago.  I've tried different
permutations of the LD kernel assumption, but all fail.  One note tho,
the wrf.exe file will work in single cpu mode *with* the kernel
environment set to 2.4.2, and it also runs under mpi, albeit a private
version in a user directory, but they are both identical builds.

    Is there any other work-arounds someone could point me to, or
perhaps some documentation that might explain what the thing is doing?
Not a lot of real good info that a non-programmer can understand in the
mpich manpages, but still no mention of errors possible like this. 

    Running in single CPU mode takes about 5 hours, where the dual CPU
method, based on the old version of the code only takes a shade ovver
2.25 hours.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20060226/45a4f559/attachment-0001.html>