[CentOS] sk98lin Gigabit Ethernet

Mon Feb 27 21:41:24 UTC 2006
Josh Kelley <joshkel at gmail.com>

Is anyone using sk98lin Gigabit Ethernet adapters under CentOS 4.x? 
The version of the driver that ships with CentOS 4.x kernels was too
old to support the onboard NICs on some Intel server boards that we
recently got, so we installed a newer driver using DKMS.  However,
we're having problems finding a stable driver to use: the first
version that we tried (7.09) gave a kernel panic when I ran ethtool,
and the latest two versions (8.30 and 8.31) periodically lose network
connectivity and give kernel errors similar to the following:

KERNEL: assertion (flags & MSG_PEEK) failed at net/ipv4/tcp.c (1293)
UDP: bad checksum. From to ulen 118
UDP: short packet: From 191/20 to

I saw that skge is recommended as a replacement for sk98lin, so I
tried recompiling a skge module based on the patch at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167768, but it
failed to recognize my card.  (I may have compiled it incorrectly.)

Can anyone recommend a version of the sk98lin driver that works
reliably?  Alternatively, can anyone recommend a good Gigabit NIC
that's recognized by a stock CentOS 4.x kernel?


Josh Kelley