[CentOS] Unable to mount SMB drive

Sat Feb 4 03:21:12 UTC 2006
Benjamin Smith <lists at benjamindsmith.com>

On Friday 03 February 2006 17:20, John Merritt wrote:
> Did you add the smbuser? smbpasswd -a

John, I tried it. 

smbpasswd -a <username>

then tried mounting it again, and (unfortunately) got the same "permissions 
denied" error when I ran smbmount and then checked it with df. 

I'm not running a samba server, I'm accessing a share from a Win2003 system, 
and my understanding of smbpasswd is that it would be used for setting 
passwords for a local share as accessed by other client systems. Am I missing 

I used the same smbmount invocations previously with a Windows 2000 server, 
but it got upgraded to Windows 2003, and things broke. 

The part that has me really scratching my head is that, while I persistently 
get this permission denied error when I try to smbmount the partition, I can 
access it fine with smbclient, not only listing files, but saving them to the 
local system! 

"The best way to predict the future is to invent it."
- XEROX PARC slogan, circa 1978