[CentOS] Problems with IDE RAID on specific motherboard

Fri Feb 17 21:02:24 UTC 2006
Paul <subsolar at subsolar.com>

On Fri, 2006-02-17 at 11:03 -0800, Benjamin Smith wrote:
> On Thursday 16 February 2006 18:36, Paul wrote:
> > 
> > > Currently, it's got an ASRock "M810LMR" motherboard in it. 
> > > http://www.ciao.co.uk/ASRock_M810LMR__5410842
> > 
> > Looks like this board is based on a early socket A VIA chipset ...
> > generally I would avoid these.  My past experience with older VIA
> > chipsets has been less than good ... I've had issues with buggy IDE
> > implementations in KT266 & KT133A and having to run them in PIO mode
> > rather than DMA mode (SLOW).
> My conclusion, as well. (and yes, it runs in PIO mode, and it's slow, and I 
> don't care since this system isn't a high-load system) 
> > I would use a cheap PCI IDE card and see what happens.
> It's a 1U system. PCI cards are pretty much out of the question.

Hmmm have you tried switching off dma in grub (IIRC adding ide0=nodma
ide1=nodma to the kernel line should do that)?  It sounds like you may
have tried that.

I would also run the drives on separate IDE cables, looks like you tried
that, but maybe not in conjunction with nodma

Paul Berger