[CentOS] Detecting second network interface

Mon Feb 20 18:15:40 UTC 2006
Bart Schaefer <barton.schaefer at gmail.com>

On 2/20/06, William L. Maltby <BillsCentOS at triad.rr.com> wrote:
> On Sun, 2006-02-19 at 14:03 -0800, Bart Schaefer wrote:
> > The ASUS P5N32-SLI motherboard in my new machine has dual NICs but
> > CentOS has only detected one of them.  I've tried rebooting with the
> > network plugged in only to the second one, but kudzu still doesn't
> > find it.
> Maybe too basic, but make sure it is enabled in the BIOS.

Did that.  Both are.

> Then as
> debugging process disable one currently detected and see if you can get
> the second detected.

Did that too.  The second one is detected that way (which led to some
fun with its MAC address not matching the HWADDR that kudzu had
previously put in ifcfg-eth0) but that doesn't help once the first one
is enable again.

> Check to see if drivers are loaded.

They are.  I also downloaded and built the nvnet driver from
nvidia.com, and turned off the forcedeth driver, but that doesn't
change anything.

I'm going to transcribe a little section from the motherboard manual
here and then tell you what I see in /etc/sysconfig/hwconf.  The

Dual Gigabit LAN
  Marvell(R) 88E8053 Gigabit LAN controller
  Marvell(R) 88E1115 Gigabit LAN PHY
  NVIDIA nForce(TM) 4 SLI built-in Gibabit MAC with
    external Marvell(R) PHY supports:
    - NV ActiveArmor
    - NV Firewall

My first thought is "what the heck is an SLI MAC?"  SLI is supposed to
be video display technology.  Now here's hwconf:

class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: unknown
desc: "Marvell Technology Group Ltd. 88E8053 Gigabit Ethernet Controller"
vendorId: 11ab
deviceId: 4362
subVendorId: 11ab
subDeviceId: 5321
pciType: 1
pcidom:    0
pcibus:  5
pcidev:  0
pcifn:  0
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: nvnet
desc: "nVidia Corporation CK804 Ethernet Controller"
network.hwaddr: 00:15:F2:66:49:A7
vendorId: 10de
deviceId: 0057
subVendorId: 1043
subDeviceId: 81d3
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 13
pcifn:  0

I've tried manually creating an ifcfg-eth1 and pointing the sk98lin
driver at eth1, but all that accomplishes is generating a message
about "device appears not to be present".

Incidentally the sk98lin driver works fine on eth0, too -- as do both
forcedeth and nvnet.  None make any difference to eth1.

What I suspect is happening is that a single (?) nVidia SLI controller
is somehow intended to operate both Marvell NICs, and Linux is not
able to distinguish them as separate devices.  But I'm not enough of a
hardware geek to know for sure.