[CentOS] sk98lin Gigabit Ethernet

Mon Feb 27 23:16:53 UTC 2006
James Pearson <james-p at moving-picture.com>

On 27/02/06, Josh Kelley <joshkel at gmail.com> wrote:
> Is anyone using sk98lin Gigabit Ethernet adapters under CentOS 4.x?
> The version of the driver that ships with CentOS 4.x kernels was too
> old to support the onboard NICs on some Intel server boards that we
> recently got, so we installed a newer driver using DKMS.  However,
> we're having problems finding a stable driver to use: the first
> version that we tried (7.09) gave a kernel panic when I ran ethtool,
> and the latest two versions (8.30 and 8.31) periodically lose network
> connectivity and give kernel errors similar to the following:
> KERNEL: assertion (flags & MSG_PEEK) failed at net/ipv4/tcp.c (1293)
> UDP: bad checksum. From to ulen 118
> UDP: short packet: From 191/20 to
> I saw that skge is recommended as a replacement for sk98lin, so I
> tried recompiling a skge module based on the patch at
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167768, but it
> failed to recognize my card.  (I may have compiled it incorrectly.)
> Can anyone recommend a version of the sk98lin driver that works
> reliably?  Alternatively, can anyone recommend a good Gigabit NIC
> that's recognized by a stock CentOS 4.x kernel?

You might want to look at the RHEL4 test patches by John Linville - see:


These patches tend to find their way in the the RHEL4 kernel

i.e. the patch:


You might have to a bit of minor work to get it to apply to the
current RHEL4/CentOS4 kernel sources - although, to see if it would
work, you could try one of the precompiled test kernels first.

James Pearson