[CentOS] IPtraf not looking right on the console..

Wed Feb 1 11:32:58 UTC 2006
Will McDonald <wmcdonald at gmail.com>

On 01/02/06, WipeOut <wipe_out at users.sourceforge.net> wrote:
> I have a CentOS 4 server at home where we store all our data, I wanted
> to get some idea of the amount of traffic going into and out of the
> server by protocol so I installed IPtraf..
> When I run it from an ssh session it looks fine but when I run it
> directly on the server console its doesn't look right at all.. It
> doesn't seem to layout correctly..
> Is there something I need to do differently on the console to run it?

It's probably a terminal type thing. I've noticed in Putty instead of
getting vertical and horizontal "bars" in the curses interface I get
xxxxxx and qqqqqqq with l-m-k-j in the corners.

Running from the console actually displays properly for me.

There are a bunch of various rendering options within Putty to deal
with this I think.

Try each of the following from your terminal/console...

export TERM=vt100; iptraf
export TERM=linux; iptraf
export TERM=xterm; iptraf

You can also increase your console resolution (with care).

Getting a Hi-Res Console

 640x480  800x600  1024x768  1280x1024
256  0x301  0x303  0x305  0x307
32k  0x310  0x313  0x316  0x319
64k  0x311  0x314  0x317  0x31A
16M  0x312  0x315  0x318  0x31B

 640x480  800x600  1024x768  1280x1024
256  769  771  773  775
32k  784  787  790  793
64k  785  788  791  794
16M  786  789  792  795

Edit your grub or lilo config and add vga=NNN where NNN is either the
hex or decimal equivalent to your desired resolution from the tables

title White Box Enterprise Linux hi-res (2.6.9-5.0.5.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.0.5.EL ro root=/dev/Vg00/Lv00 vga=773
        initrd /initrd-2.6.9-5.0.5.EL.img