[CentOS] SATA RAID Controller Support?

Tue Feb 14 18:11:37 UTC 2006
Ryan Pitt <ryan at marinocrane.com>

Aleksandar Milivojevic wrote:
> According to Adaptec web site, seems they are selling directly only 4, 
> 8 and 16 ports cards in 2x10SA series (2410SA, 2810SA and 21610SA 
> respectively).  Your 6-port version is probably OEM card made by 
> Adaptec exclusively for system integrators.  My guess is that it 
> should work with standard aacraid device driver (like the rest of the 
> cards in 2x10SA series), if you can get the driver to recognize the 
> card.  When it says that it can't find any hard drives during 
> installation, click on the option to manualy load driver, then add 
> aacraid driver to list of drivers to be loaded.
> Looking at kernel source (Centos 4.2, kernel-2.6.9-22.EL), the card 
> seems to be listed in drivers/scsi/aacraid/linit.c file.  If it 
> doesn't work for you, then Dell probably used its own PCI ID for the 
> card (you can check the file and see if PCI ID in line for 2610SA is 
> the same as the one in your card).  There are also catch-all lines at 
> the end of the list.
I tried these drivers and nothing worked.
I have just tried Fedora Core 5 Test 2 release and it finds the card 
right away just by booting to disk 1. Perhaps the next version of CentOS 
will support these cards by default.
Thanks for the reply.