[CentOS] Problems with IDE RAID on specific motherboard

Thu Feb 16 23:07:02 UTC 2006
Oliver Schulze L. <oliver at samera.com.py>

Check, IDS cables, jumpers, BIOS settings.

Also, download the .iso support CD from the manufacturer (western 
digital, seagte, etc)
and boot with that CD, check SMART and hardware and re certificate your 
to be fault free.

Then, try it again. I thinks its a hardware issue


Benjamin Smith wrote:
> About 9 months ago, I made a policy decision to adopt RAID 1 on all systems I 
> admin. (about 20 systems, all told) It's been a long, slow process. 
> One of the systems is being upgraded from CentOS3 to CentOS4. It's been 
> rock-solid stable for over a year. It's a "frankenserver" with parts from all 
> over the place, maintained over years of active service. 
> Currently, it's got an ASRock "M810LMR" motherboard in it. 
> http://www.ciao.co.uk/ASRock_M810LMR__5410842
> When I install the O/S (I've tried CentOS 4.0 and 4.2) with IDE RAID, it 
> bombs, takes hours just to format the drives, and won't reboot, getting stuck 
> at "GRUB". But, when I install the SAME TWO DRIVES without RAID, (eg: some 
> partitions on one drive, some on the other) it works perfectly. 
> I've tried putting both drives on separate IDE cablels, using completely 
> different drives, and trying CentOS 4.0 and 4.2. 
> When I try to set up IDE raid while it's taking a very long time to format the 
> drives, I see lots of errors about DMA on the alternate consoles, and there 
> being only one drive (unable to start RAID array, only 1 drive found) even 
> though the installer and disk druid have no problem reporting both drives. It 
> comes down to something like "/dev/mdN delayed until /dev/mdX is synchronized 
> because they share physical resources"... 
> I'm stumped, and falling back to non-RAID because this system is needed in 
> production. And, I'm not new to using software RAID, I've been using it for 
> years without issue. 
> Any idea what's going on? 

Oliver Schulze L.
<oliver at samera.com.py>