[CentOS] RE: Broadcom NIC Binding under Centos 4.2

Robin Mordasiewicz robin at bullseye.tv
Thu Jan 19 15:56:04 UTC 2006


On Thu, 19 Jan 2006, ABOKHALAF, Nassri Abdellatif wrote:

> Still stocked with this NIC binding problem.
> With Robin's conf both nics work fine in the active-backup config
> (thanks Robin !)
> I wanted to go a little bit further & bind both interfaces in an
> active-active conf.
> James pointed out the Documentation/networking/bonding.txt. (thanks
> James!)
> It states that there is a HA-mode where both NIC'S can work in
> active-active mode.
> I've configured the switch to operate in trunk mode for my VLAN and
> configured my CENTOS box to aggregate the links, but cannot manage to
> ping my gateway. All interfaces show the same mac addr what is good but,
> arp -a shows nothing !
>
> Question:
>
> Documentation does not say how or if you have to configure de  bonding
> mode for HA in /etc/modprobe.conf. From my point of view it should be
> mode=6 (balance-alb), but since it does not work I must be wrong! Or
> should it be left empty ?
>
> Any clues ? Could it be the switch ?

It looks like you switch is configured to use tagged vlans. If you want to 
use tagged vlans your bonding configuration must be slightly different. If 
you do not want to use tagged VLANS then your cisco must be configured to 
use access ports rather than trunk ports.


> My conf:
>
> Switch - Cisco 3750
>
> interface GigabitEthernet1/0/19
> description DNS1
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 201
> switchport mode trunk
> end
> !
> interface GigabitEthernet1/0/18
> description DNS2
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 201
> switchport mode trunk
> end
>
> /etc/modprobe.conf
> alias bond0 bonding
> options bonding miimon=100
> alias eth0 tg3
> alias eth1 tg3

I do not see a mode=x line in your modprobe.conf
modprobe.conf shuld contain
mode=1


If you want to use tagged vlans then change the following configs.


/etc/modprobe.conf

alias vlan 8021q
alias bond0 bonding
options bonding miimon=100 mode=1

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
ONBOOT=yes


Then add the following config file.

/etc/sysconfig/network-scripts/ifcfg-bond0.201
DEVICE=bond0.201
IPADDR=10.10.4.27
NETMASK=255.255.255.0
ONBOOT=yes

and modify the following

< /etc/sysconfig/network >
NETWORKING=yes
HOSTNAME=dns
GATEWAY=10.192.32.254
GATEWAYDEV=bond0.201

You must then configure your cisco as such


Switch - Cisco 3750

interface Port-channel1
  description DNS Trunk Group
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 201
  switchport mode trunk
!

interface GigabitEthernet1/0/18
  description DNS1
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 201
  switchport mode trunk
  channel-group 1 mode on
!

interface GigabitEthernet1/0/19
  description DNS2
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 201
  switchport mode trunk
  channel-group 1 mode on
!


Keep in mind that spanning tree may take up to 45 seconds to do it';s 
thing before your interfaces can ping the gateway.



More information about the CentOS mailing list